Outage accessing devices in certain locations
Incident Report for Perfecto
Resolved
This incident has been resolved.
Posted Mar 31, 2022 - 13:53 UTC
Investigating
We are currently working on resolving the problem.
Posted Mar 31, 2022 - 13:39 UTC
This incident affected: Mobile Manual (US-PHOENIX, CANADA, UK, GERMANY) and Mobile Automation (US-PHOENIX, CANADA, UK, GERMANY).