The maintenance concluded at 6:15PM EST. Due to an unstable power source, a rollback was necessary. The team will reevaluate and schedule a future maintenance to complete the necessary work.
Posted May 30, 2025 - 22:41 UTC
Completed
The scheduled maintenance has been completed.
Posted May 30, 2025 - 22:00 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 30, 2025 - 20:00 UTC
Scheduled
Perfecto will be conducting maintenance and adding additional power capacity to one of the Desktop Web racks in our US-East (BOS) data center. During this time there is expected interruption for 90 minutes for service with MacOS Web cradles in this data center. Windows Desktop Web will not be affected at this time and should continue to run as expected.
Posted May 16, 2025 - 16:43 UTC
This scheduled maintenance affected: Web Automation (US), Web Manual (US), and Scriptless (for Web) (US).