Germany Site Outage

Incident Report for Perfecto

Resolved

The underlining issues with Mobile Device connectivity has been resolved. Device Support team is working on restoring connectivity to remaining devices in error.
Posted Sep 10, 2026 - 22:35 UTC

Identified

Connectivity to the site was recovered at 16:00 UTC (12:00 PM EDT), we are still working on recovering all services.
Posted Sep 10, 2026 - 18:10 UTC

Investigating

Mobile and Web testing services are currently unavailable at our Frankfurt, Germany location. The issue is under investigation.
Posted Sep 10, 2026 - 15:30 UTC
This incident affected: Web Automation (Europe), Web Manual (Europe), Mobile Manual (Germany), and Mobile Automation (Germany).