Degraded Performance on EU-Hosted Clouds

Incident Report for Perfecto

Resolved

This incident has been resolved.
Posted Mar 02, 2025 - 10:25 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 02, 2025 - 08:46 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 02, 2025 - 08:15 UTC

Investigating

We are currently investigating an issue affecting mobile devices
Posted Mar 02, 2025 - 07:45 UTC
This incident affected: Mobile Manual (UK, FRANCE, GERMANY) and Mobile Automation (UK, FRANCE, GERMANY).