Devices hosted in the Boston Datacenter are currently inaccessible.
Incident Report for Perfecto
Resolved
This incident has been resolved.
Posted Mar 27, 2024 - 09:11 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 27, 2024 - 08:34 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 27, 2024 - 08:33 UTC
Investigating
We are currently investigating this issue.
Posted Mar 27, 2024 - 07:00 UTC
This incident affected: Web Automation (US), Web Manual (US), Mobile Manual (US-BOSTON), Mobile Automation (US-BOSTON), and Virtual Devices (iOS Simulators - US-BOSTON, Android Emulators - US).