Canada datacenter limited availability
Incident Report for Perfecto
Resolved
This incident has been resolved.
Posted Sep 08, 2023 - 09:23 UTC
Update
The problem is now resolved
Posted Sep 08, 2023 - 09:22 UTC
Investigating
We are investigating the problem
Posted Sep 08, 2023 - 08:47 UTC
This incident affected: Mobile Manual (CANADA) and Mobile Automation (CANADA).