Monitoring has been successful with no further issues observed. This incident is now considered resolved. Thank you for your patience during this time.
If you continue to see the warning, please clear your browser cache.
Posted Sep 25, 2025 - 07:54 UTC
Monitoring
Issue has been resolved by Google as false positive, site classification has been corrected to safe. We will continue to monitor.
Posted Sep 24, 2025 - 16:02 UTC
Update
Some customers may see a warning in your web browser, such as Chrome, during login to Perfecto Cloud stating that the site is dangerous. This alert is triggered by Google Safe Browsing, which recently errantly flagged the site for suspected phishing activity. Important: This is a false positive. Perfecto Cloud remains secure, and you can safely bypass the warning to continue your work as normal. We are actively working with Google to resolve this issue and remove the incorrect classification. We will provide updates as soon as they become available
Posted Sep 24, 2025 - 15:11 UTC
Investigating
During login to their clouds customers might see waring in chrome that Perfecto's site is dangerous:
Chrome has built-in safety features to protect you while you browse – like Google Safe Browsing, which recently found phishing on the site that you tried visiting. Phishing sites pretend to be other sites to trick you.
This is not the case however. The message can be bypassed and work with the cloud can continue as normal.
We are working on resolving this with out IT team and will be providing updates as these become available.