Sydney Data Center Power Outage

Incident Report for Perfecto

Resolved

This incident has been resolved.
Posted Oct 25, 2024 - 19:33 UTC

Investigating

Our team is currently investigating an outage at our Sydney Datacenter. During this time access to devices will be limited.
Posted Oct 25, 2024 - 17:27 UTC
This incident affected: Mobile Manual (AUSTRALIA) and Mobile Automation (AUSTRALIA).