Service Degradation Detected in New UI Reports

Incident Report for Perfecto

Resolved

This incident has been resolved.
Posted Apr 08, 2025 - 08:50 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 08, 2025 - 08:34 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 08, 2025 - 08:16 UTC

Investigating

We are currently investigating this issue.
Posted Apr 08, 2025 - 08:09 UTC
This incident affected: Reporting (US, APAC).