Devices disapear from livestream after 1 minute

Incident Report for Perfecto

Resolved

This incident has been resolved.
Posted Sep 08, 2026 - 15:00 UTC

Investigating

We are currently investigating this issue.
Posted Sep 08, 2026 - 14:08 UTC
This incident affected: Live Stream App (APAC, Canada, Europe, US).