Video streaming isn't available

Incident Report for Perfecto

Resolved

This incident has been resolved.
Posted Apr 01, 2021 - 15:13 UTC

Investigating

We are currently investigating the issue
Posted Apr 01, 2021 - 15:13 UTC
This incident affected: Mobile Manual (US-BOSTON, US-PHOENIX, CANADA), Visual Analysis (US), and Live Stream App (US).