France Site Outage
Incident Report for Perfecto
Resolved
This incident has been resolved.
Posted Feb 11, 2020 - 10:32 UTC
Investigating
Mobile testing services are currently unavailable at our France location.

The issue is currently under investigation.
Posted Feb 10, 2020 - 17:58 UTC
This incident affected: Mobile Automation (FRANCE) and Mobile Manual (FRANCE).