Network Disruption - All Regions Impacted

Incident Report for Perfecto

Resolved

This incident has been resolved.
Posted Mar 20, 2025 - 10:00 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 20, 2025 - 08:55 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 20, 2025 - 08:44 UTC

Update

We are continuing to investigate this issue.
Posted Mar 20, 2025 - 08:42 UTC

Update

We are currently investigating a network disruption affecting our US data centers (Boston&Phoenix).
Posted Mar 20, 2025 - 07:23 UTC

Investigating

We are currently investigating a network disruption affecting our Boston data center.
Posted Mar 20, 2025 - 07:14 UTC
This incident affected: Mobile Manual (US-BOSTON, US-PHOENIX, CANADA, UK, FRANCE, GERMANY, AUSTRALIA, BRAZIL, MEXICO) and Mobile Automation (US-BOSTON, US-PHOENIX, CANADA, UK, FRANCE, GERMANY, AUSTRALIA, BRAZIL, MEXICO).