Service Degradation in PHX Data Center

Incident Report for Perfecto

Resolved

This incident has been resolved.
Posted Mar 10, 2025 - 13:05 UTC

Identified

There has been a Utility issue in our Phoenix Data Center. Currently the Data Center is being maintained under generators. The current estimated time of resolution is Wednesday, March 12 19:00 EDT.
Posted Mar 07, 2025 - 23:58 UTC
This incident affected: Mobile Manual (US-PHOENIX) and Mobile Automation (US-PHOENIX).