Desktop Web devices in US East region have no internet access
Incident Report for Perfecto
Resolved
This incident has been resolved.
Posted Mar 18, 2024 - 17:28 UTC
Update
Our network team is closely working with external vendors to resolve the problem.
Posted Mar 18, 2024 - 14:09 UTC
Update
We are continuing to work on a fix for this issue.
Posted Mar 18, 2024 - 11:41 UTC
Update
We are continuing to work on a fix for this issue.
Posted Mar 18, 2024 - 10:37 UTC
Identified
We are still working with our vendor on resolving the issue.
Posted Mar 18, 2024 - 09:31 UTC
Investigating
We are currently investigating this issue.
Posted Mar 18, 2024 - 06:45 UTC
This incident affected: Web Automation (US), Web Manual (US), and Scriptless (for Web) (US).